Skip to main content

Content Starts Here

How do I tell Collaborator to use a specific version of Java on Linux/Unix platforms?

Question
How to specify the java version to use on *unix operating systems
Answer
Note: Please do not change any part of the script files other than the line mentioned here.

The installer for Unix/Linux platforms are provided as script/text-based files, and as such, they can be edited if necessary.
Most *nix distributions are shipped with OpenJDK installed already which Collaborator does not support.
In this case, Administrators will be asked to install a supported version of Oracle Java that is supported by their Collaborator Instance.  

Once the supported version of Oracle Java is installed, do the following:
  1. Find the script file:
    • Collaborator Server: <collab-server install dir>/ccollab-server
    • GUI Client: <collab-client install dir>/ccollabgui
    • Command-Line Client: <collab-client install dir>/ccollab
  2. Use a text editor to open the desired script and find this line:
    #INSTALL4J_JAVA_HOME_OVERRIDE=
    Uncomment the line above and append the path to the correct Java version after the equal sign. See an example below: 
    INSTALL4J_JAVA_HOME_OVERRIDE=/path/to/java
  3. Save and close the file.
     
  4. Restart the Collaborator server or re-launch the applications for this change to take effect.
Previous MonthNext Month
SunMonTueWedThuFriSat